viernes, 19 de octubre de 2012

Medibuntu, solución al error de gpg en Lubuntu 12.10

Ayer salio la nueva versión de la distribución mas ligera, Lubuntu 12.10. La he instalado y actualizado en mis ordenadores, (esto merece un post aparte), y al instalar los repositorios medibuntu.


sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

Al final del proceso la terminal me suelta al final un error.

Leyendo lista de paquetes... 

W: Error de GPG: http://packages.medibuntu.org quantal InRelease: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 2EBC26B60C5A2783 

Joder... ya empezamos, así que manos a la obra y procedemos a solucionarlo... 

Vamos a utilizar los 8 últimos caracteres de la pupkey que nos ha dado el error. En nuestra querida terminal introducimos la siguiente variable... 

PUBKEY=0C5A2783 

Después  escribimos el comando que nos va a actualizar la dichosa pubkey... 

gpg --keyserver subkeys.pgp.net --recv-key $PUBKEY && gpg -a --export $PUBKRY | sudo apt-key add - && sudo apt-get update 

Tras esto veremos que la actualización se hace normalmente y sin errores.

Recordaos que estos comando se han ejecutado en una terminal con derechos de root... 

sudo su 



Saludos a Todos

No hay comentarios:

Publicar un comentario